Unnumbered Ethernet VLAN interfaces

If you’re upgrading your Service Provider network from ATM- or SDH-based core to Carrier Ethernet core, you could be tempted to keep the unnumbered point-to-point links. The practice of using unnumbered P2P links is debatable, but if you want to, you can configure them on VLAN interfaces in recent IOS releases.

You’ll find more details (and caveats) in the Unnumbered Ethernet VLAN interfaces article in the CT3 wiki.

5 comments:

  1. The described usage case resembles me of nailing something with a microscope.
    IP unnumbered has a much wiser application in FTTB deployments, that is covered only in Russian-speaking communities, as far as I see. It is related to the vlan-per-user network design that makes access cheap requiring only dot1q (and if necessary MVR) on switches. Each client is assigned to a separate vlan, each vlan is terminated at the SVI on the distribution switch (e.g. Cat3550). If clients are provided with public IP it is wasteful to assign a /30 subnet between the PC or CPE and SVI, so here IP unnumbered comes to rescue.
    In result, sample distribution switch config looks like this:
    !
    interface Loopback 0
    ip address 10.0.0.1 255.255.252.0
    !
    interface GigabitEthernet 0/1
    description ===To access switch at building #1===
    switchport mode trunk
    switchport trunk allowed vlan 500-550
    !
    interface Vlan 500
    description ===Client #500 @ building #1===
    ip unnumbered Loopback 0
    ip proxy-arp
    !
    interface Vlan 501
    description ===Client #501 @ building #1===
    ip unnumbered Loopback 0
    ip proxy-arp
    !...so on
    ip route 10.0.0.2 255.255.255.255 Vlan 500
    ip route 10.0.0.3 255.255.255.255 Vlan 501

    Last routes may be unnecessary if DHCP relay is deployed.

    ReplyDelete
  2. Thanks for the feedback. I have also found another application (large-scale server farms) and will definitely write about both of them.

    ReplyDelete
  3. Huh, just though of that, would be interesting to see how CEF adjacencies are created over those unnumbered links. Proxy ARP? I'll try to lab this one ASAP.

    There are "point-to-point" VLANs, i.e. VLANs with no MAC address learning enabled, which works pretty much like P2P logical circuits (or hubs :). Thos are not the EVCs, but simple VLANs with no MAC address learning.

    Wonder if one can instruct CEF layer to simply push the VLAN header instead of "gleaning" for the destination MAC when switching packets over the unnumbered P2P subinterface.

    ReplyDelete
  4. You still need destination MAC address (because the receiving Ethernet controller expects it) and there are exactly two ways of getting it: using ARP or static ARP entries.

    CEF adjacencies are created as expected: next-hop in the IP routing table is tied to the interface and the router believes ARP will succeed (like with interface static route).

    ReplyDelete
  5. Yeah, but theoretically you may use broadcast destination as it should not matter on the P2P link (provided that the Ethernet transport is configured properly). Would actually save time on ARPing and resolving the "glean" adjacencies.

    ReplyDelete

You don't have to log in to post a comment, but please do provide your real name/URL. Anonymous comments might get deleted.

Ivan Pepelnjak, CCIE#1354, is the chief technology advisor for NIL Data Communications. He has been designing and implementing large-scale data communications networks as well as teaching and writing books about advanced technologies since 1990. See his full profile, contact him or follow @ioshints on Twitter.