Quick quiz: OSPF LSA generation

Given the following OSPF configuration …

interface Loopback 0
 ip ospf 1 area 0
!
interface Ethernet 0
 ip ospf 1 area 0
!
interface Serial 1
 ip ospf 1 area 0
!
router ospf 1
 passive-interface Ethernet 0

… how many LSAs will the router originate? Leave your opinions in the comments.

16 comments:

  1. 2 LSAs- LSA Type 1 and LSA Type 2

    ReplyDelete
  2. Assuming the passive-interface default, i'll say 2 LSA Type 1 : one for Loopback and another for The Serial.
    And one LSA Type 2, the number depends of the nb of routers in the AREA.

    ReplyDelete
  3. No LSA will be generated

    ReplyDelete
  4. The passive interface command only suppresses hellos on that interface, so an LSA type 1 will still be generated for that interface it just won't establish any neighbors on that interface.

    So, LSA type 1 for each interface: serial, loopback and ethernet.

    Assuming serial interface is p2p, no LSA type 2 will be generated.

    ReplyDelete
  5. The passive interface e0 will prevent any OSPF adjacencies forming over that interface, hence there will be only 1 router on the e0 lan segment, & hence no Type 2 LSAs, as 2 or more routers on same lan segment are required for a DR election.

    My answer: 1 LSA (Router LSA)
    E0, S1 & Lo0 will be seen as stub networks by OSPF.

    ReplyDelete
  6. No LSAs will be generated, the interfaces have no ip address and when you go ahead and try to start the OSPF process it will fail.

    ReplyDelete
  7. Four. One for each of the interfaces. One for the router.

    ReplyDelete
  8. Assuming all interfaces have IP address configured on them otherwise OSPF commands will not be allowed in Cisco IOS.

    By default, OSPF treats Loopback interfaces as STUB NETWORKS and will advertise them as STUB ROUTES (with mask /32). No LSAs are sent for loopback interfaces but they are still advertised. 8-)

    OSPF treats ethernet interfaces as Broadcast network and hence generate LSA Type 1 & 2.

    OSPF treats serial interfaces as Point-to-point network and hence only LSA Type 1.

    ReplyDelete
  9. Router will generate only one Type 1 LSA, which describes all IPv4 links in "up" state.

    ReplyDelete
  10. Doh!
    Galvezc is right.
    No ip addresses = no ospf process = no lsas.

    Assumed that ip addresses were configured :)

    ReplyDelete
  11. Assuming that there are IP addresses configured on all interfaces, and that all interfaces up, there will be two LSAs generated. A Type-1, which will include information on Lo0 and Se1, and a Type-2, for Et0.

    Ethernet interfaces are treated as broadcast by default. As the Et0 interface is set to passsive, no adjacencies can form and this router can not participate in a DR election; it will therefore declare itself the DR for the Ethernet segment and originate a Type-2 LSA.

    (Of course, this assumes that all interfaces have been bound to an OSPF area; there are no 'network' or 'ip ospf area' commands to be seen...)

    ReplyDelete
  12. From the sh running command, all I can say is that 2 LSA's will be generated. LSA 1 and 2. Only logical explanation in my mind is that only area 1 is defined.

    ReplyDelete
  13. hahaa :) nice quiz :)

    ReplyDelete
  14. OSPF protocol will be down on interface as ip address is not configured, so LSAs will not be originated.

    ReplyDelete

You don't have to log in to post a comment, but please do provide your real name/URL. Anonymous comments might get deleted.

Ivan Pepelnjak, CCIE#1354, is the chief technology advisor for NIL Data Communications. He has been designing and implementing large-scale data communications networks as well as teaching and writing books about advanced technologies since 1990. See his full profile, contact him or follow @ioshints on Twitter.